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Let’s face it, for some companies Portable Document Formats (PDFs) are an unfortunate necessity. From sell sheets and downloadable product flyers, to manuals and tutorials - PDFs have secured a spot in our lives, and there are some tips and tricks that can be implemented to secure a spot in the Search Engine Results Pages (SERPs) as well.

This blog post will cover how to optimize PDFs to rank better using Adobe Acrobat Pro DC, some basic how-tos, and how Googlebot crawls PDFs when Search Console is set to mobile-first indexing. We will also be covering how to add alt text to our PDFs to make them accessible for all readers. If you have Adobe Acrobat Pro DC, follow along with us as we optimize our PDF file for the web! 

It’s important to note that we are not recommending using PDFs to drive traffic in the least, rather we are making the most of a limited format that many companies are unfortunately tied to. If you need to rank for a term, we would unequivocally avoid PDFs at all costs, but we have to face reality on reality's terms.
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Why Optimize PDFs for the Web? The Benefits and Drawbacks of SEO for PDFs

The majority of modern search engines, such as Google or Microsoft Bing, index PDFs along with pages and images. However, most companies don’t treat PDFs like they would a web page. By following best practices for Search Engine Optimization (SEO) like including title tags, meta descriptions, internal/external links, and alt text in our PDF files, these files will be more helpful & valuable to your audiences. Search engines will also be able to better understand the content, thereby ranking it higher up in the search results for relevant keywords. 

As mentioned earlier, it’s also worth noting that optimizing PDFs for the web should be only used out of necessity. Creating high-quality, informative web pages is the proper way to earn your ranking in the SERPs, and opens you up to a world of better possibilities like tracking & analytics, testing, mobile-friendliness & much more. This post is designed to provide optimization information to readers whose website already contains a large amount of PDF content. 

We would not recommend creating PDFs and optimizing them just for SEO purposes alone. PDFs should only be used if required by legal, or if they are the best format available to deliver information to your readers.

SEO For PDFs: How-Tos

In this section I’ll show you how to optimize your PDFs similar to traditional website SEO best practices. Before reading this section, you should already know the basics of search engine optimization. If you don’t, you should check out our SEO writing guidelines so you can quickly get up to speed.

Adding Title Tags and Meta Descriptions to PDFs

To add title tags and meta descriptions to your PDF file, first navigate to Properties underneath the File dropdown. 

In the window that opens, click on “Additional Metadata…”





From here you can add your title tag and meta description to the “Document Title” and “Description” sections respectively.





You can also include other information as well, like the author of the PDF or the main keywords. These ancillary details won’t have an impact on search rankings but will give proper attribution.

Creating a New File Name for Your PDF

Creating a new file name is pretty self explanatory, to do this you can either rename the file or go to File → Save As, and create a new file name for the new version of the PDF you’re saving. Since the file name is going to be part of the URL, you want to include keywords just as you would when creating a URL for a webpage. It’s generally a good idea to match the name of the file to the name of the PDF so users know what they’re getting into when they click on the PDF URL. When you find the need to input a space into the file name, we recommend using a dash instead of an underscore.

Adding Links to Your PDF

To add an external link to text, you can highlight the text you’d like to link and right click to select “Create Link”. To add an external link to an image, just right click on the image to select “Create Link”.

A pop-up appears with the option to go to a page view, open a file, or open a web page. Select “open a web page”, then click “next” to enter in the URL for your link.





Note: Because PDFs don’t have the ability to be tracked in JavaScript-based analytics packages like Google Analytics, you may want to add tracking parameters to your links so you can see how much traffic is coming from your PDFs. You can also track PDF downloads in Google Tag Manager using the Click URL.

To add an internal link to text or an image, right click and select “Go to a page view” in the same window. Adobe will prompt you to navigate to the section of your PDF that you’d like to link to, then click on “Set link”. Adobe will then add the internal link to that element automatically.





Online PDF Security

In Adobe, the only way to guarantee that no one can edit your PDF file is by password protecting it or encrypting it with Certificate Security. 

If you password protect your PDF, users must have the password that you specified in order to view the document. If you use Certificate Security, you specify which recipients you want to view the document. 

In either situation the general public will not be able to access your PDF file which isn’t ideal for a product flyer or any other material that’s available for download online. Unfortunately this means that there’s always a risk that your PDF can be edited by others.

Adding Alt Text to PDF Files

To add alt text to images, go to View → Show/Hide → Navigation Panes → Tags to pull open the Recognition Report. In the Summary, the Recognition Report will alert you to images and figures missing alt text. In this document, 39 of our figures do not have alt text. Click the link to view a complete list.





Once you’ve accessed the list, you can see which images/figures don’t have alt text. To add alt text, click on “Tags” on the left sidebar.





Now right click on the first figure and select “Properties”. This will pull up the object properties for the figure where you can edit alt text.





When you’re done adding alt text to all figures and images, you should use Adobe’s built-in screen reader to read the document back to you and check for errors. To do this, go to View → Read Out Loud → Read To End Of Document.

How Does Googlebot Crawl PDFs?

Search engines like Google typically won’t crawl PDFs too often since the content rarely changes. If you do update your PDFs to include some of the previously mentioned SEO and accessibility best practices, you can include the file links in a sitemap and resubmit that sitemap to Google Search Console to encourage Googlebot to recrawl your pages.

PDFs and Mobile-First Indexing

Most websites today are using mobile-first indexing in Google Search Console, meaning that Googlebot is crawling the mobile version of your webpages. 

As long as you still have links into your PDFs (on both mobile & desktop) your PDFs will still be indexable.
There are a lot of opportunities to make your PDF files more SEO friendly and accessible to the web, from title tags and meta descriptions to alt text and external linking. For more fun with PDFs, check out this blog post to learn how to create interactive PDFs as part of your content marketing strategy!

If you want to learn the ins and outs of writing for SEO or just want to brush up, we’ve got you covered. Download SEO Writing Guidelines for Beginners to gain access to our writing checklist and template for title tags & meta descriptions.
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Search Engine Optimization
Empowering Marketers: How CypresSEO Streamlines SEO Tasks


Discover how CypresSEO revolutionizes SEO for marketers, streamlining tasks and empowering your strategies. Enhance your SEO efficiency with our AI-powered tool.
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B2B Marketing
B2B Marketing With the Rise of Gen Z: Navigating the Digital Native Workforce


Explore the unique challenges & opportunities of marketing to Gen Z in the B2B space. Discover how these digital natives are reshaping the professional world & what it means for marketing strategies. Stay ahead in the era of Gen Z with expert insights.
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Content Marketing
What Do ChatGPT & Other AI Mean for Content Writers?


With ChatGPT taking the internet by storm, should content writers be concerned? Here’s everything writers should consider.
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Search Engine Optimization
Testing Website Accessibility: Five Testing Tools & Methods To Identify Accessibility Issues


Is your site compatible with website accessibility guidelines? Use these tools to benchmark and identify improvement opportunities. Website accessibility is often overlooked, but it shouldn’t be. According to CDC estimates, 61 million adults in the United States alone live with […]
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Digital Marketing Training
23 Of The Best Resources For Starting A Digital Marketing Career


The best social media communities, podcasts, newsletters, and certifications for new digital marketers I didn’t know anything about digital marketing when I started as an intern at Cypress North earlier this year. Acronyms like SEO, CPA, and ROAS meant nothing […]
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Content Marketing
A Marketer’s Website Launch Checklist


SEO, Google Tag Manager Tracking, & Content Planning for a New Website There’s nothing quite like launching a beautiful, brand new website, but it is something that can have ugly consequences if not performed correctly. While marketers aren’t typically responsible […]
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B2B Marketing
How to Use Adobe Acrobat Pro DC to Make Interactive PDFs For Inbound Marketing


Creating unique downloads for your content marketing campaign can be a struggle.  With millions of resources available online, how can you distinguish your downloads from the assets your competitors are providing? By making them interactive of course! You can unlock […]
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Content Marketing
Should You Hire A Digital Marketing Agency or Hire In-House: An Unbiased Breakdown


Many small businesses (SMBs) hit that point of growth where they know that they need digital marketing help. That is non-negotiable. But is it better to hire an in-house digital marketers or use an agency? This is an important conversation that we have fairly frequently, so we set out to make the ultimate list of pros and cons of hiring a digital marketing agency.
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B2B Marketing
Best Digital Marketing Podcasts


Whether you're focused on SEO, PPC, social media, content, or affiliate marketing, podcasts are a great way to stay competitive in the dynamic digital marketing landscape. Finding a reliable program to consume from your car, desk, or treadmill allows you […]
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Digital Marketing Training
Updated: How To Exclude Mobile Apps From Google Ads Display Campaigns


If you’ve been following us for a while, you’ll know we generally don’t like running ads on mobile apps. Don’t get us wrong, we love apps! They’ve made it easier than ever before to get information and connect with each […]
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Display Advertising & Retargeting
Digital Marketing in 2019: What to Watch For


The Pros Rampant Responsive One of the biggest boons for advertisers in 2018 was the ability to optimize campaigns by moving away from standard banner sizes and utilizing responsive display ad formats. The proliferation of flexible ads such as Facebook […]
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Paid Search Marketing
Firing Up Bing Ads? Crucial Differences Between Bing & AdWords To Consider When Setting Up Your Campaigns


Does Anyone Even Use Bing? As digital marketers we tend to hear this question on a weekly basis, if not more often. And while the mere idea that Bing exists is enough to shatter the worldview of many Google nerds/religious Chrome users, the […]
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Data Analysis
Getting Started With Google Tag Manager


What is Google Tag Manager? Google Tag Manager (GTM) is a tool that gives users a way to add code to a website without having to log in to the backend and manually add to the source code every time. […]
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Display Advertising & Retargeting
The Retargeting Playbook: The Ultimate Guide To Setting Up Successful Retargeted Ads


As an internet user, you’ve likely become accustomed to those ads that seem to follow you during all your digital travels. These ads are known as “retargeted” ads (or “remarketed” ads if you're using Google) and help to keep your […]
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Content Marketing
Time Flies & Terrible Lies: July Content Marketing Ideas...NOT


Sooooo, remember last month when I said: Come back again next month for some July-inspired content marketing ideas you can really sink your teeth into... you know, as if you were a T-Rex or something. Well, it appears that I […]
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Content Marketing
Candy, Cabins & Color TV: June-ified Content Marketing Ideas


Ermagerd! June is almost upon us. Is your editorial calendar up to snuff? If you waited until the last minute to plan out your content marketing for the month, you're in luck! We're here with our helpful post, just in […]
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Content Marketing
Packrats, Playoffs & Plenty Of Flowers: May Content Marketing Inspiration


Hey you! Did you know that in just one day... Boy I love that gif. It's been a pretty popular one around our office this week, you know, since it's the best way to ring in the month of May […]
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Content Marketing
Fools, Frogs & Furious 7: April Content Marketing Ideas


For those of you that spent the last month crying over my lack of content marketing post (just kidding, I love you all and appreciate that you were saddened by my absence), I have big news for you... I'M BACK […]
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Content Marketing
Friendship, Fat Tuesday & The Fish Bowl: Content Marketing Inspiration For February


Dear February, Just because you have less days than everyone else doesn't mean you're any less of a month. In fact, what I love so much about you is that you're just as chuck-full-o-nonsensical (and serious) observances as all the […]





 











 








 

Blog
by:
Jess Budde




12.23.2014


Content Marketing
Bubble Wrap, Bubble Baths & Belly Laughs: Content Marketing In January Fashion


The new year is fast approaching, and you know what that means... a brand new content marketing strategy for 2015! As you've likely gathered, we love nothing more than inspiring you to make great content. Baby New Year comes complete with […]
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